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1 Introduction 

PepSlide® Analyzer (PSA) facilitates microarray image analysis and data quantification. The software 

is particularly useful for peptide array users; you can benefit from analyses that directly support 

peptide array applications such as epitope mapping, biomarker discovery, and characterization or 

optimization of peptides.  

This Quick Start Guide describes basic commands to enable immediate access to the functionalities 

of the software solution. Please find more details in the User’s Guide. 

1.1 Installation 

PSA is natively supported on Windows and Mac OS X platforms, thus the software is able to run with 

high performance and native look. Installation of PSA requires rights of a system administrator. 

Hardware Requirement 

Minimum hardware: 1.5 GHz Processor, 1GB RAM. 

Recommended hardware: 2.0 GHz Dual-Core or faster Processor, 2 GB or more RAM. 

Windows Platforms 

PSA works on Windows XP, Windows 7, and Windows 8. Simply run the PSA setup. If the current 

account is not administrator, you will be asked to input an administrative account and password. 

Mac OS X platforms 

The software runs on Mac OS X 10.7 and 10.8. Unzip the package and double-click on the .pkg file to 

launch the installer. During installation you will be prompted to provide a system administrator’s 

account and password. Upon completion, PSA is installed in folder /Applications/PepSlide/Analyzer. 

1.2 Product Activation 

After installing PSA® on Windows, you need to activate the software with a trial serial number 

obtained from the software provider or its distributor. This enables the use of PSA® with full 

functionality for 14 days. The trial use for PSA® on Mac OS X platforms is handled automatically and 

does not require this step. 

When the free trial time has expired, you can buy a software license to continue using PSA®. Upon 

the purchase, you receive a serial number and use it to activate the license. Please refer to the 

product activation steps here. 

 

http://www.sicasys.de/pepslide/pricing/
http://www.sicasys.de/pepslide/help/activation/
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2 Software User Interface 

Related software controls are grouped in labeled components as shown in Fig. 1. We refer to a 

software component using the name listed in Table 1. 

 

Fig. 1: The Software User Interface. 

Area Component Name 

 The menu 

 The canvas toolbar 

 The main toolbar 

 The control panel 

 The canvas 

 The Spot Image widget 

 The table of quantified data 

Table 1: Area Names. 

The main toolbar enables quick access to a group of related functions summarized in Table 2. Clicking 

a button on the main toolbar opens the control panel containing controls for these functions and the 

sheet that displays the data and the processed results. 
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Select image channel.  

Change image’s intensity.  

Rotate images.  

Peptide Library Analysis:  

Support epitope mapping, peptide 
optimization, etc. 

 

View properties of spot families 
(SF), blocks, and spots.  

Rotate and move SF or blocks.  

Hierarchical Clustering Analysis:  

Show peptides and samples on a 
heat map with their correlation.  

 

Quantify the array data and browse 
the quantified data. 

 

Principal Component Analysis:  

Select important peptides and 
samples. 

 

Show spots in a scatter plot 
according their quantified data. 

 

Batch Processing: 

Automatically process and quantify 
multiple array images. 

Table 2: The Main Toolbar and Related Functions. 

3 Peptide Array Analysis Diagram 

The analysis diagram (Fig. 2) summarizes the steps for analyzing a single peptide array slide or a 

batch of multiple slides. Please note that in this manual, the term array is used to mean both array 

and microarray, unless otherwise stated. 

 

Fig. 2: The Analysis Diagram 

Section 4 details the steps to analyze a single slide if the array file is of PSF format (*.psf). If you are 

using GAL files (*.gal), please find these steps in Section 5. The steps to analyze multiple slides 

automatically are described in Section 6. 

Load image(s) 

Load array 

Align array 

Quantify array data 

Analyze peptide libraries 

Analyze a single slide 

Create and execute a batch  

Identify important peptides and 
samples, and their relationships 

Analyze multiple slides 



 

PepSlide® Analyzer Quick Start Guide Version 2.0 Page 4 

4 Analyze a Single Slide with a PSF File 

1 

 

Load the image of the peptide array slide and observe the image data: 

 Click the Images > Open Image menu and select the array image file. 

 Assign the image signal to either Red channel or Green channel. 

Suppose that the Red channel was chosen.  The canvas then shows the image with signal 

as red pixels (Fig. 3a); the stronger the signal, the brighter the pixels. 

 
 

PSA supports uncompressed TIFF images. For image quality we recommend 16-bit 

grayscale images. (8-bit grayscale or 24-bit color images are also supported.) 

1.1 If the slide contains both peptides and controls, and they are separately scanned into two 

TIFF images or a two-page TIFF image: 

 Assign signal of each image (or each page) to either Red channel or Green channel. 

To show the signal of only peptides, or only controls, or both: 

 Open the Images control panel. 

 In the Image Channels section, select Red, Green, or Combined respectively. 

1.2 To view the image and the signal at a proper scale: 

 Use the Zoom In and Zoom Out buttons on the canvas toolbar. Alternatively, select or 

enter a zoom level in the Zoom combo-box. 

1.3 To increase the signal’s visibility: 

 Open the Images control panel. 

 In the Image Intensity section, enter a positive contrast number (e.g. 75) or select the 

Enhance contrast automatically option. 

2 

 

Load the array file (*.psf) and view the array data: 

 Click the Arrays > Open Array menu and select the array file. 

The array is then overlaid on top of the image in the canvas. 

 
The array consists of spot families. A spot family (abbreviated SF) is a group of 

spots generated from the same source, such as a peptide library or a control.  

In the canvas, a spot is illustrated as a white rectangle (Fig. 3a). Thus an SF is seen 

as a grid of white rectangles. 

2.1 View properties of an SF or a spot: 

 Open the Arrays control panel.  

 To view an SF’s properties, click to open the Spot Family page in the Array Object 

section. Then hover the mouse over the SF or click on it in the canvas. 

 A spot’s properties, which include the amino acid sequence, can be seen by opening 

the Spot page and then hovering mouse over the spot or clicking on it in the canvas. 

3 

 

Align the array to correctly associate spots in the array with their signal in the image: 

 Improve the spots’ visibility. (Refer to Step 1.3.) 

 Based on the spot pattern, particularly from control spots, you may need to: 

 Rotate the image. 

 Move the SFs. 

 Rotate the SFs. 

 Save the aligned position of the array. 



 

PepSlide® Analyzer Quick Start Guide Version 2.0 Page 5 

3.1 To rotate the image: 

 In the Image Rotation section: 

 Flip horizontally and/or vertically. 

 Rotate images at angles of 90°, 180°, or 270°. 

The rotated image can then be saved with the Images > Save Image As menu. 

 
 

You may want to check if the image should be flipped horizontally. A hint is to look 

at the control spots at the top-left corner and their signal in the image. 

3.2 To select SFs containing spots that need reposition: 

 Open the Arrays control panel and then click on the Spot Family page. 

 To select individual SFs, click on them while pressing the Ctrl key. 

 Click Ctrl-A to select all SFs in the array. 

3.3 To move SFs: 

 Select SFs. 

 Click on the selection and drag the corresponding SFs to the intended position. 

 
 

In the image, the spots’ signal is shown in red, green, or a color different from 

white. Reposition the SFs such that for each spot, the inner region bounded by the 

dashed rectangle is as close to the spot’s signal as possible (Fig. 3a). 

3.4 To rotate SFs: 

 Select SFs. 

 In the Array Rotation section, enter the rotation angle and direction. 

 
 

If the array slightly deviates from the image at a small angle, it is recommended 

that the relevant SFs be rotated, since image rotation may change the image data. 

3.5 To save the aligned position of the array: 

 Choose the Arrays > Save Array menu to save the aligned array to the current file. 

 Save the aligned array to another PSF file using the Array > Save Array As menu. 

4 

 

Quantify the array data: 

 Make sure the array is correctly aligned with the image. 

 Click the Quantify button on the main toolbar to start the quantification procedure. 

 Upon finishing, the results are updated into the table of quantified data, each row 

showing the intensity values of each spot. Suppose you assigned the peptide signal to 

the Red channel, you may use the following values for finding spots of interest: 

 Red Foreground Mean or Red Foreground Median 

 If spot replication is employed: Aggregate Red Foreground Mean (or Median) 

 
 

Quantification is a complex process which involves many concepts. If you want 

detailed information, please check the User’s Guide (Section 1.3 - Software 

Concepts and Section 4 - Quantification of Array Data). 

4.1 View the quantified data: 

 In the canvas, clicking on a spot shows the row in the table of quantified data that 

contains the spot’s intensity values. 

 Alternatively, selecting a row in the table also highlights the associated spot in the 

canvas. You can thus conveniently browse the quantified data with navigation keys 

such as Up, Down, Page Up, and Page Down. 
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4.2 

 

Observe hits with the scatter plot: 

 Click the Scatter Plot button on the main toolbar to display spots in the 2D-chart 

according to their quantified data. 

 Select an SF in the Spot families box in the Scatter Plot control panel to show only 

spots of that SF. 

 Use the blue bars to select positive spots. Their data, including the peptide, is then 

updated into the table below the chart and can be exported to a CSV file. 

4.3 Save the quantified data to a CSV file: 

 Click the Export to CSV File button. 

4.4 Save the analysis results: 

 Choose the Project > Save Project menu to save the analysis results to a PepSlide® 

Analyzer project file (*.psa). 

 
 

The project file, e.g. named s1.psa, contains the path to the image, the aligned 

array, and the quantified data. When later opening s1.psa with the Project > Open 

Project menu, the image, the aligned array, as well as the quantified data will be 

reloaded. 

5 

 

Analyze peptide libraries: 

 Make sure the quantified data is available. (Refer to Step 4.) 

 Click the PLA button on the main toolbar to start the analysis. Upon finishing, the 

results are shown in the Peptide Library Analysis sheet. 

 
This tool facilitates analyses with respect to the peptide array application. If e.g. an 

antigen is translated into overlapping peptides for epitope mapping, the software 

may suggest a list of peptides which represent an epitope. In the case a peptide’s 

variants are generated by substituting its residues with desired amino acids, you 

can observe all variants and their intensity value simultaneously, and easily select 

those of interest. 

This analysis thus depends on how a peptide library is generated. For detailed 

steps, please check the User’s Guide (Section 5 - Analysis of Peptide Libraries). 

 

 
If you encounter the warning message: “Please specify the peptide library design 

for the following spot families”, it means that from the array file, the software does 

not know how the peptides are generated. Please contact the peptide array 

provider for further information. 

 

  

(a) Rectangular Spot (b) Circular Spot 

Fig. 3: Spots in PepSlide® Analyzer. 
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5 Analyze a Single Slide with a GAL File 

1 

 

Load the image of the peptide array slide and observe the image data: 

 Click the Images > Open Image menu and select the array image file. 

 Assign the image signal to either Red channel or Green channel. 

Suppose that the Red channel was chosen.  The canvas then shows the image with signal 

as red pixels (Fig. 3b); the stronger the signal, the brighter the pixels. 

 
 

PSA supports uncompressed TIFF images. For image quality we recommend 16-bit 

grayscale images. (8-bit grayscale or 24-bit color images are also supported.) 

1.1 If the slide contains both peptides and controls, and they are separately scanned into two 

TIFF images or a two-page TIFF image: 

 Assign signal of each image (or each page) to either Red channel or Green channel. 

To show the signal of only peptides, or only controls, or both: 

 Open the Images control panel. 

 In the Image Channels section, select Red, Green, or Combined respectively. 

1.2 To view the image and the signal at a proper scale: 

 Use the Zoom In and Zoom Out buttons on the canvas toolbar. Alternatively, select or 

enter a zoom level in the Zoom combo-box. 

1.3 To increase the signal’s visibility: 

 Open the Images control panel. 

 In the Image Intensity section, enter a positive contrast number (e.g. 75) or select the 

Enhance contrast automatically option. 

2 

 

Load the array file (*.gal) and view the array data: 

 Click the Arrays > Open Array menu and select the array file. 

The array is then overlaid on top of the image in the canvas. 

 
The array consists of blocks. A block is a group of spots located next to each other.  

In the canvas, a spot is illustrated as a white square (Fig. 3b). Thus a block is seen 

as a grid of white squares. 

2.1 View properties of a block or a spot: 

 Open the Arrays control panel.  

 To view a block’s properties, click to open the Block page in the Array Object section. 

Then hover the mouse over the block or click on it in the canvas. 

 A spot’s properties can be seen by opening the Spot page and then hovering mouse 

over the spot or clicking on it in the canvas. 

3 

 

Align the array to correctly associate spots in the array with their signal in the image: 

 Improve the spots’ visibility. (Refer to Step 1.3.) 

 Based on the spot pattern, particularly from control spots, you may need to: 

 Rotate the image. 

 Move the blocks. 

 Save the aligned position of the array. 

If the spots’ signal is sufficient the software may be able to align the array automatically. 

If this is not the case, use steps 3.2 to 3.4 to align the array manually. 
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3.1 To align the array automatically: 

 In the Array Object section, click the Align Array button. 

 
 

You can check the array alignment result by increasing the signal’s visibility (Refer 

to Step 1.3) and verifying if for all spots, the inner region bounded by the dashed 

circle aligns well with the spot’s signal (in green or red pixels, Fig. 3b). If this is the 

case, go directly to step 3.5 to save the aligned array. 

3.2 To rotate the image: 

 In the Image Rotation section: 

 Flip horizontally and/or vertically. 

 Rotate images at angles of 90°, 180°, or 270°. 

The rotated image can then be saved with the Images > Save Image As menu. 

3.3 To select blocks containing spots that need reposition: 

 Open the Arrays control panel and then click on the Block page 

 To select individual blocks, click on them while pressing the Ctrl key. 

 Click Ctrl-A to select the entire array. 

3.4 To move blocks: 

 Select blocks. 

 Click on the selection and drag the corresponding blocks to the intended position. 

 
 

In the image, the spots’ signal is shown in red, green, or a color different from 

white. Reposition the blocks such that for each spot, the inner region bounded by 

the dashed circle is as close to the spot’s signal as possible (Fig. 3b). 

3.5 To save the aligned position of the array: 

 Choose the Arrays > Save Array menu to save the aligned array to the current file. 

 Save the aligned array to another GAL file using the Array > Save Array As menu. 

4 

 

Quantify the array data: 

 Make sure the array is correctly aligned with the image. 

 Click the Quantify button on the main toolbar to start the quantification procedure. 

 Upon finishing, the results are updated into the table of quantified data, each row 

showing the intensity values of each spot. Suppose you assigned the peptide signal to 

the Red channel, you may use the following values for finding spots of interest: 

 Red Foreground Mean or Red Foreground Median 

 If spot replication is employed: Aggregate Red Foreground Mean (or Median) 

 
 

Quantification is a complex process which involves many concepts. If you want 

detailed information, please check the User’s Guide (Section 1.3 - Software 

Concepts and Section 4 - Quantification of Array Data). 

4.1 View the quantified data: 

 In the canvas, clicking on a spot shows the row in the table of quantified data that 

contains the spot’s intensity values. 

 Alternatively, selecting a row in the table also highlights the associated spot in the 

canvas. You can thus conveniently browse the quantified data with navigation keys 

such as Up, Down, Page Up, and Page Down. 
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4.2 

 

Observe hits with the scatter plot: 

 Click the Scatter Plot button on the main toolbar to display spots in the 2D-chart 

according to their quantified data. 

 Select a block in the Blocks box in the Scatter Plot control panel to show only spots of 

that block. 

 Use the blue bars to select positive spots. Their data is then updated into the table 

below the chart and can be exported to a CSV file. 

4.3 Save the quantified data to a CSV file: 

 Click the Export to CSV File button. 

4.4 Save the analysis results: 

 Choose the Project > Save Project menu to save the analysis results to a PepSlide® 

Analyzer project file (*.psa). 

 
 

The project file, e.g. named s1.psa, contains the path to the image, the aligned 

array, and the quantified data. When later opening s1.psa with the Project > Open 

Project menu, the image, the aligned array, as well as the quantified data will be 

reloaded. 

5 

 

Analyze peptide libraries: 

 Make sure the quantified data is available. (Refer to Step 4.) 

 Specify the peptide design library as described in Section 5.4 - Peptide Library 
Analysis with GAL Files - of the User’s Guide. 

 Click the PLA button on the main toolbar to start the analysis. Upon finishing, the 

results are shown in the Peptide Library Analysis sheet. 

 
This tool facilitates analyses with respect to the peptide array application. If e.g. an 

antigen is translated into overlapping peptides for epitope mapping, the software 

may suggest a list of peptides which represent an epitope. In the case a peptide’s 

variants are generated by substituting its residues with desired amino acids, you 

can observe all variants and their intensity value simultaneously, and easily select 

those of interest. 

This analysis thus depends on how a peptide library is generated. For detailed 

steps, please check the User’s Guide (Section 5 - Analysis of Peptide Libraries). 

 

6 Analyze multiple slides with a GAL File 

Suppose that the study is to screen a peptide array with k samples. This employs k slides of the 

peptide array whose annotation is based on a single GAL file, the so-called template array. The 

screening of k slides results in k scanned images. You can then setup a batch to automatically process 

all k images and generate their quantified data. 

The current version of PepSlide® Analyzer only supports batch processing for GAL files and circular 

spots. The images are either one-page or two-page grayscale TIFF files. In addition, the spots’ signal 

in the images should be sufficient for positioning the array. 

 



 

PepSlide® Analyzer Quick Start Guide Version 2.0 Page 10 

1 

 

Create and execute the batch: 

 Click the Batch button on the main toolbar to create a new batch. 

 In the Batch control panel, specify the images, and template array, and the options.

 Execute the batch.

1.1 To specify parameters and options of the batch: 

 Click the Add button and select the images for processing.  

 Double-click on the Template array edit-box to browse to the template array file. 

 Specify the folder to store generated files. 

 Finally, save the batch to a file using the Batch > Save Batch menu. The batch log is 

created automatically and named after the batch file. 

 
 

For each batch, we recommend using a separate folder to store the batch file and 

generated data files. 

1.2 Execute the batch: 

 Click the Run button to start the batch. During execution, the status of the currently 

processed images will be updated. 

Suppose that sample001.tif is an image in the batch. Three data files are then generated 

for this image: 

 sample001.gal: the array file in which the array’s spots are associated with their 

signal in the image sample001.tif, 

 sample001.csv: the CSV file containing only the quantified data, and 

 sample001.psa: the project file containing the analysis data for the image. 

As a result, k project files (*.psa) will be generated for a batch of k images. They can be 

used for discovering important peptides and samples as well as their relationships in Step 

2 and Step 3. 

2 

 

Identify important peptides and samples with Principal Component Analysis (PCA): 

 Click the PCA button on the main toolbar.  

 In the PCA control panel:  

 Click the Load Data button and select the k project files (*.psa). 

 Select a screening value in the Data Column list-box, e.g. Red Foreground 

Mean or Red Foreground Median.

2.1 To find peptides that influence the variance of the study: 

 Choose Simplify the dataset to three Samples. 

 Click the Start Analysis button. 

2.2 To find samples that influence the variance of the study: 

 Choose Simplify the dataset to three Features. 

 Click the Start Analysis button. 

 
 

In addition to PSA project files (*.psa), the PCA tool also accepts a list of GenePix 

Result files (*.gpr) or a CSV file prepared in the suitable dataset format.  

For detailed steps on the dataset and the PCA tool, refer to Section 7.1 – Dataset - 

and Section 7.2 - Principal Component Analysis - of the User’s Guide. 
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3 

 

Discover relationships between peptides and samples with Hierarchical Clustering 

Analysis (HCA): 

 Click the HC button on the main toolbar.  

 In the HCA control panel:  

 Click the Load Data button and select the k project files (*.psa). 

 Select a screening value in the Data Column list-box, e.g. Red Foreground 

Mean or Red Foreground Median. 

 Choose to construct the clustering tree for features (i.e. peptides), or 

samples, or both of them. 

 Click the Start Analysis button. 

The Hierarchical Clustering sheet then shows a heat map. It is like a matrix of boxes with 

rows representing peptides and columns representing samples. Consider the box at row 

p and column s, its color represents the screening value of peptide p against sample s. 

In addition, samples that are related (e.g. those that response similarly to a certain group 

of peptides) are grouped into a cluster. Their relationship is illustrated by a line 

connecting them. The relationship between peptides is similarly illustrated. 

3.1 To review the screening result of peptide p against sample s:  

 Observe the color of the corresponding box on the heat map. 

3.2 To identify the relationship between peptides or between samples: 

 Observe the clusters and the line connecting them. 

 
 

In addition to PSA project files (*.psa), the HCA tool also accepts a list of GenePix 

Result files (*.gpr) or a CSV file prepared in the suitable dataset format.  

For detailed steps on the dataset and the HCA tool, refer to Section 7.1 – Dataset - 

and Section 7.3 - Hierarchical Clustering Analysis - of the User’s Guide. 

 


