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1 | Introduction

1 Introduction

Spotxel® Microarray, formerly Spotxel® Microarray Image and Data Analysis Software, offers easy-to-
use and intuitive tools for microarray image and data analysis. The software supports image analysis,
automated processing of multiple images, replicate processing, data filtering, and data
normalization. These features enhance data quality and reliability, facilitating the identification of
key features and samples and the exploration of their relationships through data mining tools.

1.1 Installation

Spotxel® Microarray runs natively on both Windows and Mac OS X platforms. Depending on the
installation directory, installing the software may require system administrator rights.

Hardware Requirement

Recommended hardware: 1.3 GHz Quad-Core or more powerful processor, with 8 GB or more RAM.

Windows Platforms

The software is compatible with 64-bit versions of Windows 7, Windows 8, Windows 10, and
Windows 11. To install the software:

e Run the installer.
e If the current Windows account is not an administrator, you will be prompted to enter an
administrative account and its password.

Mac OS X platforms

The software is compatible with Mac OS X 10.7 and later versions. To install the software:

o Double-click on the installer to initiate the setup program.

e Confirm the installation directory when prompted; by default, this is set to
SHOME/SpotxelMicroarray.

e Once the installation is complete, navigate to the installation folder and click on the Spotxel
app to launch the software.

1.2 Product Activation

After installing Spotxel® Microarray on Windows, you may want to activate the software with a trial
serial number. This allows you to use premium functionalities such as data quantification, automatic
array alignment, and batch processing of multiple images.

For Mac OS X platforms, the trial use of Spotxel® Microarray is automatically managed and does not

require activation.
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1 | Introduction

It is important to note that the GAL Array Editor module, along with the functionality for handling
microarray images, is entirely free and becomes accessible immediately upon software installation,
with no license required.

When the free trial period expires, you can purchase a software license for continued use of
premium functions. Upon purchase, you will receive a serial number to activate the license.

1.3 Upgrade

Simply run the installer for the new version to upgrade. The software configuration will be handled
automatically. You do not need to activate the software again if it has already been activated.

1.4 Software User Interface

Associated software controls are grouped in labeled components (Figure 1). We refer to a software
component using the name listed in Table 1.

X Spotxel Microarray - o X
Project Images Arrays Analysis Batch Configurations View Help @

*) Zoomin =) ZoomOut 50% @

Control Panel -
Images Image Channels @
O Red
Colorize I

Arrays
Physical Dimensions: 2,20 x 6,90 centimeters
Resolution: 1.000,00 x 1.000,00 pixels/cm

Pixel Dimensions: 2200 x 6900 pixels

Description: 635 [W11
Image Intensity
Norm
Enhance contrast automatically
© Change contrast manually 0 £
HC I
Change brightness manually 0 [

PCA

Invert the image
Image Rotation

Batch
Flip

@ Vertically Horizontally

Rotate at an angle

O 90° E B — - =
Ready

Figure 1: The Software User Interface.

Component | Component Name

The menu

The canvas toolbar

The main toolbar

The control panel

The canvas

OOOEE

Table 1: Software Components.
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1 | Introduction

The main toolbar provides quick access to a group of related functions. They are described in Table 2.
Clicking on a button on the main toolbar opens the control panel for the function group. The
software displays the data and the analysis results in a sheet on the right of the control panel.

Select image channel.

e . , ) Process replicates, filtering data,
eee Change image’s intensity. )
Thages i and normalize data.

Rotate images.

. - Hierarchical Clustering Analysis:

@ Add, edit, rotate and move blocks.
. . , - Show features and samples on a

. View and edit spots’ ID and name. He ) . )

heat map with their correlation.

. Principal Component Analysis:
STk Quantify the array data and browse o| .
e . - Select important features and
Qantify the quantified data. pcA

samples.

Batch Processing:
% Automatically process and quantify

many microarray images.

Table 2: The Main Toolbar and Related Functions.
1.5 Terms and Concepts

In this manual, the term array refers to the spot layout and annotation of a microarray. We assume
that the array is saved as a GenePix Array List (GAL) file. The term image or microarray image
denotes a scanned or captured image of the printed microarray.

Figure 2: A rectangular block with 6 spots. Figure 3: A hexagonal grid with 16 spots.

An array consists of blocks, each being a group of spots located next to each other. On the canvas, a
spot is illustrated as a white square in a rectangular block or a white hexagon in a hexagonal block.
Figure 2 shows a rectangular block with two rows and three columns. Figure 3 presents a hexagonal
block with sixteen spots arranged in four rows and four columns. Within each spot, the spotted
region is defined by the area bounded by the dashed circle, with its diameter specified by the spot
diameter parameter for each block.

The binding signals of a microarray tested with a sample are converted by a microarray scanner or
camera into a digital array image containing a matrix of pixels. Each pixel has a gray value
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2 | Setting Up for Microarray Image and Data Analysis

representing pixel intensity. Array images are often saved in the TIFF format'. In 8-bit grayscale
images, the gray value ranges from 0 to 255, while in 16-bit grayscale images, it ranges from 0 to
65535. Since 16-bit grayscale images have a broader range of signal levels, they are recommended
for array image analysis.

Quantification is the procedure that estimates the true binding signal for each spot and represents its
signal value using the mean and median of pixel intensities within that spot. The quality of
guantification depends on the spot finding or spot detection procedure, which determines which
pixels in the array image belong to a spot. Background correction also contributes to quantification
quality by estimating and removing signals caused by non-specific binding from the spot’s signal.

For each spot in the array, the median and mean of its raw, background, and foreground values are
calculated. Raw represents the intensity value of the spot’s signal. Background is the estimated value
of the signal caused by non-specific binding. The value of interest is foreground, computed by
subtracting the background value from the raw value.

Array alignment is the process of associating spots in the array with their signal in the image. The
spot’s signal is presumably due to the binding of the immobilized substance in the spotted region
with the sample. Therefore, before quantification, the array is reallocated such that the spotted
regions are as close to the spots’ signal as possible.

1.6 Key Tasks in Microarray Image and Data Analysis

From a software perspective, typical tasks in microarray image data analysis include:

1. Quantification of Microarray Data
e Load the scanned images and the array file.
e Process the image and array if necessary.
e Align the array to the images.
e Quantify the microarray data.
2. Batch Processing of Multiple Microarray Images (if necessary)
e Automate the steps in task 1 for multiple images.
3. Preprocessing the Data
e Use the data filtering and normalization tools.
4. Discovery of Key Features And Samples

e Utilize data mining tools to identify key features and samples.

The following sections explain how to accomplish these tasks using the software.

! https://download.osgeo.org/libtiff/doc/TIFF6.pdf
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2 Setting Up for Microarray Image and Data Analysis
2.1 Loading Data

To analyze the microarray data, two input data are required:

e Scanned images of the microarray in the TIFF format.
e Array file prepared in the GAL format (*.gal).

Spotxel® Microarray supports 8-bit, 16-bit, and 24-bit grayscale images. You can also use 24-bit color
images, but the dynamic range is limited. For high image quality and efficient processing, 16-bit
grayscale TIFF images are recommended.

2.1.1 Loading Images
e C(lick the Images > Open Image menu and select the image file(s).
e The software supports analyzing images in single-color mode or dual-color mode. An image
needs to be assigned to either the Red or Green channel for analysis.

For single-page images, you’ll be prompted with a dialog as shown in Figure 4 for assigning the color
channels. If only one single-page image is selected, then only a single assignment is shown.

X Channel Assignment X

Assign image signal in
file Slide3_pageO.tif tothe Green ~ channel

Slide3_page1.tif Red ~

0K Cancel

Figure 4: Loading single-page images.

X Channel Assignment X

The image contains many pages. Right-click on a page and assign it to Red or Green channel.

Pa\ée Description Channel Width x Height  Pixel Size Resolution
; 635 [P1] 220x7,15cm | 550 x 1787 250 x 250 pixels/fcm
2 532 [P2) 220x7,15em  550x 1787 250 x 250 pixels/cm
3 635 [W1] Red 1.32x1,32cm 1320x 1324 1000 x 1000 pixels/cm

4 532 [W2] Green 1,32x132cm 1320x 1324 1000 x 1000 pixels/cm

OK Cancel

Figure 5: A multi-page image with two pages having the same resolution.
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2 | Setting Up for Microarray Image and Data Analysis

In dual-color mode, you can use either two single-page images or a multi-page image. The two
loaded images, or two selected pages, must have the same resolution. The software automatically
recognizes whether the images are single-page or multi-page and prompts you with the selection.

If the multi-page image contains two pages of the same resolution (Figure 5), the pages can be
assigned to different color channels for analysis. On the other hand, if the pages are of different
resolutions (Figure 6), e.g., one is only a preview, and then you can only select the main page for
single-color analysis.

X Channel Assignment X

The image contains many pages. Right-click on a page and assign it to Red or Green channel.

Page Description Channel Width x Height Pixel Size Resolution

2,20x 537 cm 550 x 1342 250 x 250 pixels/em

532 [
- 532 [W2] m 0,80 x4,94 cm | 796 x 4944 1000 x 1000 pixels/cm

oK Cancel

Figure 6: A multi-page image with two pages having different resolutions.

2.1.2 Images without Resolution Information

Usually, TIFF images contain resolution information (pixels per inch or pixels per centimeter), which is
read automatically by the software. If this information is not available, the software prompts you to
provide it manually by displaying the Image Resolution Options dialog (Figure 7). You can also launch
this dialog via the Configurations > Image Resolution Options menu.

% Image Resolution Options X

The header of the TIFF image contains no resolution information.
Therefore, the image is displayed with the default options:

Resolution X 1000 =
Resolution Y 1000 =
Resolution unit Centimeter ~

[ Use these options for images without resolution information.

OK

Figure 7: Setting image resolution.

If you are not certain about the resolution values, you can use the default values shown in Figure 7. If
the grids appear too small relative to the spots, increase the Resolution X and Y values by a factor of
10 - for example, set them to 10,000 pixels per centimeter. To remember this setting for other
images, check the "Use these options for images without resolution information" option.

Spotxel® Microarray 3.5 User’s Guide Page 8



2 | Setting Up for Microarray Image and Data Analysis

2.1.3 Loading Array
Click the Arrays > Open Array menu and select the GAL array file.

After being loaded, the images and the array are shown in the graphical canvas (Figure 1). To obtain
an appropriate view, you can use the Zoom In and Zoom Out buttons on the canvas toolbar or select
a predefined zoom level in the Zoom combo-box. Alternatively, you can enter an arbitrary value
directly into the Zoom combo-box.

Block Block
Name Block?1 Spot
Number of columns 22 Block Block1
Number of rows 22 ID HA20383~B01R22C22
Horizontal spacing (um) 200.00 = Name AlexaAntiMouseAb~N/A
Vertical spacing (um) 200.00 = Spot position
. = Local Column 22
Spot diameter (um) 110.00 o
Local Row 22
Left-most position (um) 2630
Horizontal (um) 6830
Spot Vertical (um) 6140
Editing Editing
(a) Block Properties. (b) Spot Properties.

Figure 8: Properties of an Array Object.

2.2 Viewing Array Data

In the Array File section of the Arrays control panel, you can view properties of a block or a spot. To
show a block’s properties (Figure 8-a) in the Block page:

e Open the Block page by clicking on it.

e Hover the mouse over, or click on, the block in the canvas.

Similarly, you can open the Spot page and then points to a spot in the canvas to view its properties
(Figure 8-b).

A detailed guide on creating and editing an array file can be found in Section 3 - Managing Array
Data with GAL Array Editor. If you already have a GAL array file (*.gal) and only need to use it, you
may proceed directly to Section 3.4.

2.3 Array Alignment

As mentioned in Section 1.5, the array needs to be aligned with the image before quantifying the
microarray data. This can be done automatically or manually.

Aligning Array Automatically

e Click the Align button in the Arrays control panel.

Spotxel® Microarray 3.5 User’s Guide Page 9



3 | Managing Array Data with GAL Array Editor

e There are multiple options that can be adjusted to optimize the alignment of your arrays.
These options are detailed in Section 4.3.

Aligning Array Manually

e Please refer to Section 3 for a detailed guide of selecting, moving, and rotating blocks.

The aligned position of the blocks in the array can be saved with the Save button or the Arrays > Save
Array menu.

2.4 Spotxel Microarray Project File

It is recommended that the analysis of each microarray image be saved to a Spotxel® Microarray
project file (*.spotxelproj) using the Project > Save Project menu. The saved data includes the path to
the image, the aligned array, and the quantified data. When opening the project file with the Project
> Open Project menu, the software will load all the saved data. This enables you to manage all the
analysis data for one microarray image with a single project file. Additionally, you can use these
project files directly with data mining tools.

The paths to the microarray image, the GAL file, and the project file are shown in the Data Files
section of the Images, Arrays, and Quantification control panels.

3 Managing Array Data with GAL Array Editor

To access the Arrays functions, you first need to load your microarray image in TIFF format. The TIFF
image typically contains the resolution information (pixels per inch or per centimeter), which allows
the software to draw the array accordingly, as the values in the array design are in micrometers.

If you already have a GAL array file (*.gal) and only need to use it, you may skip the initial parts of
this section and proceed directly to Section 3.4.

3.1 Creating Blocks

To create an array file from scratch, navigate to Arrays > Array File and click on the Create button. In
the dialog that appears, you will have the following options:

e Block type: Select either Rectangular (a commonly used layout, Figure 10) or Hexagon
(orange packing) even row (Figure 11) for a more compact layout. Depending on your specific
microarray requirements, you may choose another hexagonal layout.

e Horizontal orientation: Define the number of blocks to be arranged horizontally and specify
the horizontal spacing between two blocks.

e Vertical orientation: Define the number of blocks to be arranged vertically and specify the
vertical spacing between two blocks.

e Block properties: Define the number of rows and columns of spots, the spacing between
them, and their diameter.

Spotxel® Microarray 3.5 User’s Guide Page 10



3 | Managing Array Data with GAL Array Editor

Create a new array X

| Block type (layout of spots)

Rectangular v
Horizontal orientation Vertical orientation
|
Number of blocks 2 = Number of blocks 2 =
Between spacing (um) 100.00 : Between spacing (um) 100.00 :
Left-most position (um) 100 : Top-most position (um) 100 :

Block Properties
Number of columns 12
Number of rows 3
Horizontal spacing (um) 288.00

Vertical spacing (um) 288.00

4 40 4 4 4

Spot diameter (um) 100.00

| 0K Cancel

Figure 9: Creating a New Array.

Please note that the values for spacing and diameter can be fractional, allowing for precise alignment
of the array with the spots on the image later on. After clicking OK, the blocks will be added to the
canvas. Figure 9 illustrates a sample setup, and Figure 10 shows the created rectangular blocks.

Figure 10: Rectangular Blocks.

Figure 11 presents two hexagonal even-row blocks, each with 6 rows and 12 columns, as another

example. The spot spacing are 288 pm horizontally and 249 um vertically.

Figure 11: Hexagonal (Orange-Packing) Blocks.

Spotxel® Microarray 3.5 User’s Guide Page 11



3 | Managing Array Data with GAL Array Editor

To mitigate the risk of data loss, it is advisable to frequently save your array to a file. To accomplish
this, navigate to Arrays > Array File and click on the Save button. The first time you save an array file,
a dialog box will appear, prompting you to choose the file path. Each successful save will be
confirmed on the status bar.

3.2 Extending an Array

You can extend an existing array by adding new blocks. To do this, navigate to Arrays > Array File
and click on the Editing page, followed by the Add button. A dialog box with the same parameters as
when creating a new array (as shown in Figure 9) will appear. The key difference here is that the new
blocks will be appended to the existing blocks in the array.

3.3 Editing Spots' Name and ID

You can modify the names and IDs of spots using a spreadsheet-like interface as follows:

e Proceed to Arrays > Array File > Editing page and click the Edit button. This will launch the
Array Spot Data window (Figure 12), which exhibits a table with each row containing the data
of a spot in the array.

e To edit a spot name or ID, navigate to the ID or Name cell on a row and input the new text.
Press Enter to finalize the editing for that cell. You can traverse the table using either
navigation keys or your mouse. The shortcuts Control + Home and Control + End can also be
used in this table. Remember to save the array after editing.

e The table is in sync with the graphical canvas with the image and array. Choosing a row on
the table emphasizes the corresponding spot on the canvas, and vice versa.

e You can arrange the table according to the values of a column by clicking on that column’s
header. To eliminate all sorting, double-click on any column header.

| X Array Spot Data = o X

Spotdata  Window  View
Data Filtering & X | Table of Spot Data = N
Blgck Row Column ID Name
Header column
1 1 1 1 51-1-1 n1-1-1
ID 4

O Contains
3 1 1 3 s1-1-3 mil=1=3)
O Excludes

O Regular expression

[ Case sensitive

Figure 12: Table of Spot Data.
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3 | Managing Array Data with GAL Array Editor

In addition, the Data Filtering widget on the left (Figure 12) enables you to select a field (Block, Row,
Column, ID, Name) and filter the table according to a specific pattern. Position your mouse over the
edit-boxes corresponding to the Contains, Excludes, or Regular expression options to view
explanations and examples.

This feature is optimally utilized with multiple screens, e.g., by connecting your laptop with a
monitor. Displaying the graphical canvas on the monitor and the table on the laptop screen, or vice
versa, and having them synchronized, facilitates very convenient array editing.

3.4 Selecting and Editing Blocks

Click on a block to select it. To select multiple blocks, hold down the Control key while clicking on
them. You can also select all the blocks in the array with the shortcut Control A. To deselect, click on

a point in the canvas outside of the selection.
To change the spot size and spot spacing of blocks:

e  First, select the blocks.
e Navigate to the Arrays > Array File > Block page.
e Adjust the values of the horizontal spacing, vertical spacing, and spot diameter.

e Remember to press Enter after changing a parameter.
3.5 Positioning Blocks

Align blocks with the corresponding spots on the image by selecting the blocks and dragging them to
the desired position.

Fine-tune the position of selected blocks using the position tuning shortcuts. Hold down the Control
key and press one of the four navigational keys (left, right, up, down) to shift the selected blocks a
small delta in the navigated direction. You can shift multiple times until the desired position is
reached.

The value of delta is equivalent to one micrometer and is derived from the image resolution. For
example, if the image resolution is 1000 x 1000 pixels per centimeter, or 0.1 pixels per micrometer,
then the delta shift on the canvas is equivalent to 0.1 pixels. If the derived value is less than 0.1, delta
is also set to 0.1.

3.6 Rotating Blocks

Rotate the selected blocks using the options in Arrays > Array Rotation (Figure 16-b). Here, you can
specify the center and direction of rotation. After inputting the angle value, press Enter to rotate the
blocks.

Spotxel® Microarray 3.5 User’s Guide Page 13



3 | Managing Array Data with GAL Array Editor

3.7 Undo and Redo

You can undo or redo the changes made to the blocks in the array. The revertible changes include:

e Blocks' position
e Blocks' angle

e Spot spacing and spot diameter

Activate this function with the Undo or Redo button located in the Arrays > Array File > Editing page.
Please note that the Undo and Redo functionalities are not applicable to actions such as adding block
or shifting blocks (position fine-tuning).

3.8 Shortcuts and Keyboard Support

When editing arrays, you have the option to use either the buttons in the Arrays control panel or the
keyboard shortcuts. These shortcuts are activated by holding down the Control key (Ctrl) and
pressing the corresponding key. Please refer to Table 3 for a summary of the supported shortcuts.

Shortcut Function
CtrI N Create a new array
Ctrl S Save the array
Ctrl O Open a new array
Ctrl L Align the array
Ctrl T Edit the table of spot data
Ctrl Z Undo the last change
CtrlY Redo the last change
Ctrl | Add new blocks to the array
Ctrl Home Move to the first block of array
Ctrl End Move to the last block of array
Ctrl A Select all blocks in array
Ctrl - (right-arrow key) | Shift" right
Ctrl < Shift left
Ctrl Shift up
Ctrl 4 Shift down

Table 3: Shortcuts for Editing Arrays.

Note': Shift refers to moving the selected blocks a delta distance in the specified direction.
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4 | Image and Array Processing

4 Image and Array Processing

4.1 Image Processing

Image Properties

In the Images > Image Channels section (Figure 13), you can select a color channel or both to display
in the graphical canvas. The image size and resolutions are also shown here. Other useful information
includes the TIFF description, which often contains the scanning wavelength.

Adjusting contrast and brightness

This process can make the spots more visible and ease the array alignment. These functions are
available in the Images > Image Intensity section (Figure 14).

e Choose the Enhance contrast automatically option to maximize the spot visibility.

e You can manually adjust the image’s brightness and contrast by moving the slider.
Alternatively, a value between -99 and 99 can be entered directly.

e On some images, setting the contrast to 99 and brightness to -99 also leads to the same
effect as the automatic contrast enhancement, but with less noise.

Image Channels Image Intensity
Frmam O Red Combined O Enhance contrast automatically

Colorize I © Change contrast manually 0o =
Physical Dimensions: 2,20 x 6,90 centimeters I

Resolution: 1.000,00 x 1.000,00 pixels/cm Crarge erg itnzss ranee ly 0~
Pixel Dimensions: 2200 x 6900 pixels n

Description: 635 W11 (J Invert the image

Figure 13: Image Properties. Figure 14: Image Processing.
Colorization

Another means to visualize the spots is the colorization tool (Figure 13). This depicts a grayscale
image, or a page of a multi-page image, as a color image in which a pixel’s color is determined by its
original intensity value. Figure 15 illustrates the effect of the tool. It can be seen that many spots of
weak signal have become visible in the colorized image.

Please note that this feature is applicable to 16-bit grayscale images only.
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a) Original image. b) Image after colorization.

Figure 15: Colorization.

The tool can be turned on and off by clicking on the left or right side of the Colorize switch (Figure
13). Note that a single channel, either Green or Red, must be selected first to enable the switch.

For each pixel in the original image, the tool first determines the range that the pixel intensity
belongs to and shows the pixel in the corresponding color. The number of colors is fixed, but the
ranges of intensity values are adjustable. To change the setting, click the Configuration >
Colorization Setting menu.

Inversing

Select the Inversion check-box to create the negative image.

4.2 Image and Array Rotation

Rotating images

You can flip and/or rotate images at angles of 90°, 180°, or 270°. These functions are located in the
Images > Image Rotation (Figure 16-a).

Rotating Array

If the array slightly deviates from the spots in the image at a small angle, it is recommended to rotate
the array (i.e. the relevant blocks), since image rotation may alter the image data. You can select
blocks and rotate them at an arbitrary angle. These functions are located in the Arrays > Array
Rotation section (Figure 16-b). The degree change can be as small as 0.01°.

Selected blocks can be rotated in clockwise or counterclockwise direction, with a rotation center
defined as follows:

e Global: the top-left of the image.
e Local: the top-left of each block.
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Image Rotation

Flip

(] Vertically [ Horizontally
Rotate at an angle

L+ Joy O 90°

O 180° O 270°

(a) Image Rotation

Array Rotation

Center of rotation

© Global O Local
Direction

O Clockwise (O Counterclockwise
Angle of rotation 0.00 =

(b) Array Rotation

Figure 16: Rotation of Images and Arrays.

4.3 Automatic Array Alignment

The automatic array alignment feature aligns the grids with your slide image. The process involves
three main steps:

1. Determining the rotation angle: The software detects and compensates for any rotation in
the slide image. You can skip this step if the rotation is very small (e.g., less than 0.1°).

2. Roughly determining the blocks' positions: Using the relative distances between blocks
specified in your original GAL file, the software estimates the initial positions of the blocks.
This method is practical and efficient because the GAL file reflects your array design used
during spotting. By utilizing these predefined distances, the software avoids exhaustive
searching and speeds up the alignment process.

3. Refining the blocks' positions: The software fine-tunes the alignment for each block by
optimizing their positions relative to the detected spots, taking into account any deviations
or offsets.

Importance of Relative Distances between Blocks

The relative distances between blocks specified in your GAL file are crucial for accurate alignment.
Ensuring these distances are correct allows the software to align the blocks precisely, reflecting the
intended array design.

If you experience misalignment, consider the following steps:

e Reload the GAL file: Ensure you are using the GAL file with block positions that corresponding
to your array design.
e Adjust the offsets between blocks as described in the Offset of Blocks’ Position section.

e Run the alighment again.

4.3.1 Alignment Options

Due to variations in array and spot configurations, the automatic function with the default options
may not align the grids with the image precisely at first. You can fine-tune the alighment function by
clicking the Configurations > Array Alignment Options menu. The setting dialogs are shown in Figure
17 and Figure 18.
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Alignment Signal Orientation
() Green () Red (® Combined [ Detect rotation
Maximum angle 100 =
Alignment Control Offsets Between Blocks
Select controls Poly-T-Cy5 Horizontal Offsets (ratio of spot width):
[ Position Cy5 Left-most Blocks 050 |-
Adjacent Blocks 075 =

Vertical Offsets (ratio of spot height):

Edit List ... Top-most Blocks 050 =
Adjacent Blocks 075 =
Figure 17: Alignment Options - Signal & Controls. Figure 18: Alignment Options — Orientation &

Offsets Between Blocks.

Alignment Signal

This setting (Figure 17, the Alignment Signal section) is useful for dual-color images. It allows you to
specify which channel (Red or Green) to use for array alignment. The default option is Combined,
where the software uses the strongest signal from both channels. For single-color analysis, the
alignment uses the signal from the loaded channel.

Detect Rotation

Enable this option (Figure 18, the Orientation section) to detect if the slide image is rotated and
adjust the alignment accordingly.

In the Maximum angle spin-box, you can set the limit for the potential rotation of the image, based
on the image acquisition setup. The default value is 1.0°, meaning the software will search for an
optimal angle between -1.0° and 1.0°. Please note that including rotation detection and setting a
larger maximum angle will increase the alignment processing time.

4.3.2 Offset of Blocks’ Position

Normally, adjacent blocks should have approximately the same horizontal (X) or vertical (Y) position.
However, printed blocks may be slightly offset from the planned positions. In Figure 19, we observe
differences in the horizontal position of block 1 and block 3, as well as in the vertical position of block
3 and block 4.

If the printed blocks have significant offsets from their planned positions, you might need to adjust
the offsets between blocks (see Figure 18, the Offset Between Blocks section).

Horizontal Offset (ratio to the spot width)

e [Left-most Blocks: Maximum difference in X-position between left-most blocks (e.g., block 1
and block 3 in Figure 19).

e Adjacent Blocks: Maximum difference in X-position between two adjacent blocks that are not
left-most (e.g., block 2 and block 4 in Figure 19).
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Vertical Offset (ratio to the spot height)

e Top-most Blocks: Maximum difference in Y-position between top-most blocks (e.g., block 1
and block 2 in Figure 19).

e Adjacent Blocks: Maximum difference in Y-position between two adjacent blocks that are not
top-most (e.g., block 3 and block 4 in Figure 19).

Adjusting these parameters helps the software better accommodate the actual positions of the
blocks on the slide.

o Typically, if blocks are adjacent, the offsets between them are less than 1 (e.g., 0.5 or 0.75
times the spot size).
e If blocks are spaced further apart, the offsets might be 1.5 or 2 times the spot size.

Figure 19: Offset of Blocks.

4.3.3 Alignment Controls
You can also use positional controls to optimize the alignment:

e Check the box next to the controls you want to use for alignment. In Figure 17, the control
Poly-T-Cy5 is selected.

e To add or modify a control, click the Edit List button in the Alignment Control section. The
software will show a list of all controls.

e To create a control, click the Add button. To modify an existing one, click the Change button.
In the Edit the Control dialog, specify the name, ID, and replication mode of the control spot.
Once created, the controls remain for future use.

Spots with the same Name (in the array file) as the selected alignment controls will be used as
positional markers. The array alignment will position the grids to best match these markers.
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5 Quantification of Microarray Data

5.1 Quantifying Microarray Data

To begin quantifying microarray data, click the Quantify button in the main toolbar to open the
Quantification control panel.

e To quantify the entire array, click the Quantify Array button.
e To quantify specific blocks, select the desired blocks and click the Quantify Selection button.

A new window will appear, displaying a table of the quantified data (Figure 21). Detected spots in the
canvas are highlighted with a blue border by default (Figure 20).

Canvas

Figure 20: Highlighted Spots in Canvas.

The spots in the canvas and the table of quantified data are synchronized. Selecting a spot in the
canvas (highlighted in yellow) will also highlight the corresponding row in the table, and vice versa.
This feature is particularly useful when using multiple screens, such as connecting a laptop to a
monitor. Displaying the graphical canvas on one screen and the table on the other facilitates efficient
analysis of the microarray data.

The quantification process may take some time, depending on the image resolution and array size.
Fortunately, the software supports multi-threading, allowing you to continue navigating through the
image and array data while the quantification is in progress.
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5.2 The Table of Quantified Data

X Tables of Quantified Data | HA_0001.tif | Protein_001.gal
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Figure 21: Table of Quantified Data.

In the table of quantified data, the median and mean of each spot’s

Data Filtering

Header column
[
© Contains
Excludes
Regular expression
[[] Case sensitive
Numeric columns

Keep a row if thresholds fulfilled by

© Al values
) At least
Lower threshold -16343 =
Upper threshold 65353,00

Data Normalization

Normalize

Process the data using
© 7-5core
Z-Factor with negative controls
Ratio to mean value of controls

Controls

raw, background, and

foreground values in each channel (Red and/or Green) are calculated. If a spot’s raw value is smaller

than its background value, the spot is flagged as an error, and its foreground value is set to zero.

(Section 5.3 details the methods used to calculate the raw and background values.)

2D Spot Viewer

The 2D Spot Viewer allows you to view the selected spot, its neighbors, and their quantified data

simultaneously (Figure 21, bottom-left). It displays the image portion corresponding to the selected

spot and its neighbors.

3D Spot Viewer

In addition to the two dimensional view, the 3D Spot Viewer (Figure 21, top-left, and Figure 22)

displays a three-dimensional representation of the selected spot and its neighbors. Note that both

the 2D and 3D Spot Viewers display the contrast-adjusted intensity, similar to the canvas.

To change the view and size of the 3D Spot Viewer:

e Change the viewing angle: Hold down the right mouse button and drag.

e Zoom in and out: Use the mouse wheel.
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Data Filtering, Replicate Processing, and Data Normalization

To filter spots, process replicates, or normalize the quantified data of the current microarray image,
use the tools in the Data Filtering, Replicate Processing, and Data Normalization widgets.

If you are not familiar with these tools, hover the mouse over a control, such as the edit box in Data
Filtering > Contains, and read the popup tooltip. These tools are also described in detail in Section 7.

Exporting the Quantified Array Data

You can export the quantified data to a CSV file (*.csv) or a GenePix Result file (*.gpr) for further
analysis.

Docking and Undocking a Tool

Double-clicking on the header allows you to undock the 2D and 3D Spot Viewers from the Table of
Quantified Data. They will become independent windows and can be moved to any screen and freely
resized (Figure 22). To bring an undocked viewer back to the table, just double-click on its header.
This behavior also applies to the Data Filtering, Replicate Processing, and Data Normalization tools.

3D Spot Viewer =‘
|

Figure 22: 3D Spot Viewer.

5.3 Quantification Options

To display the quantification options, check the Show quantification options checkbox in the
Quantification control panel (Figure 23). The available options depend on the selected spot detection
method, of which there are three.
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@ show quantification options

Spot Detection Method .
Spot Detection Method
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~
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Smallest spot size (%) 50 = Smallest spot size (%) 40 =
Largest defect size (%) 30 = T 35 -~
Background Correction Lower threshold 0,040 =
© Local method
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Figure 23: Flex-Spot Options. Figure 24: Feature-Based Options.
Fixed-Spot

The Fixed-Spot method always uses the pixels within the predefined spotted region (Figure 2 and
Figure 3, dashed circles) to compute the raw value. The background value is calculated based on the
pixels in the remaining area within the spot.

Flex-Spot

The Flex-Spot method (Figure 23) can flexibly detect the spot’s signals even if their shape, size, and
position do not match the predefined spotted region. The detected spot border is shown in blue
(Figure 20). The raw value is calculated based on the pixels within the blue border, while the
background value is calculated using the pixels in the remaining area within the spot.

The Flex-Spot method is the first recommendation because it does not require the spots in the image
to rigidly match their predefined regions, as specified in the GAL file.

Feature-Based

The Feature-Based spot detection method (Figure 24) is recommended for noisy images where the
Flex-Spot method fails to locate the spot correctly. This newly introduced method leverages the
Scale-Invariant Feature Transform (SIFT) algorithm?, which is a powerful feature detection technique,
but is not yet fully utilized by the software. We will continue to improve its integration in future

releases.

? David G. Lowe. Distinctive image features from scale-invariant keypoints. Int. J. Comput. Vision, 60(2):91-110,
November 2004.b
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Show Border

After data quantification with the Flex-Spot and Feature-Based methods, you can toggle the detected
spot border on and off using the Show border option (Figure 23). The software supports saving the
border information in the project file (*.spotxelproj), allowing you to observe the detected spot
border when reopening the project file. This feature is particularly useful for reviewing the quantified
data generated by batch processing.

Default Settings and Tool-Tips

If you need to revert to the default settings after making multiple changes, refer to Figure 23 and
Figure 24. Additionally, you can display tooltips by hovering over the options for further guidance.

5.4 Flex-Spot Spot Detection Options

Smallest Spot Size

Set the size limit of a valid spot using the Smallest spot size (%) parameter. For example, if set to 50%,
the Flex-Spot method will reject spots that can fit within a square with a side length of 50% of the
spot diameter. The valid values range from 25% to 100%.

Largest Defect Size

Define the maximum defect size using the Largest defect size (%) parameter, which ranges from 0%
to 50% of the spot diameter. Larger percentages will eliminate larger defects. Please note that the
elimination of defects takes place only if the Process defects checkbox is checked.

Undetectable by Flex-Spot

If the Flex-Spot method cannot detect a spot due to size limits, weak signals, or noisy data, the
software will employ the Fixed-Spot method to compute the raw value. No blue border will be shown
if the Fixed-Spot method is used.

5.5 Feature-Based Spot Detection Options

Number of Contrast Levels

Select the number of contrast levels (ranging from 2 to 5) used to improve spot detection. Higher
values may uncover more features but could slow down processing.

Smallest Spot Size

Similar to the Flex-Spot method, this parameter sets the minimum spot size as a fraction of the spot
diameter, ranging from 25% to 100%. Larger values will ignore smaller spots during detection.
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Increase Contrast

Adjust the image contrast (from -99 to 99) to enhance detection. This setting works together with the
number of contrast levels. Higher contrast settings can help reveal features across multiple levels.

Lower Threshold

Set the SIFT Lower Threshold parameter, used in the SIFT (Scale-Invariant Feature Transform)
algorithm to discard low-contrast features. The default value is 0.04. Lower values will detect more
spots but may also include more noise.

5.6 Noise Processing

By checking the Process noise option (Figure 23 and Figure 24), you can include noise processing
during the quantification procedure. This includes processing background noise, foreground noise,
and signal smearing. Noise processing effectively reduces background noise and can be regarded as
an implicit background correction method.

Background Noise

Noises in microarray images can mislead the spot detection procedure and result in incorrect
estimation of the true specific-binding signal. Figure 25-a shows a slide image with non-
homogeneous background signal, concealing specific-binding signals and affecting array alignment
and spot finding.

Equipped with powerful image processing functions, the software can process such background
noise. Figure 25-b visualizes the detected background signal alone, while Figure 25-c shows the slide
image with the background signal eliminated, revealing the spots’ signals clearly.

(a) Original image. (b) Detected background signal.
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(c) The Raw signal: The image with background signal eliminated.

Figure 25: Noise Processing.

Foreground Noise

Figure 26 illustrates a slide image with foreground noise, where two large red bands are due to non-
specific binding. The software processes such foreground noise based on the spots’ shape and size,
selecting only valid spots (in red) and highlighting them with a blue border.

Figure 26: Foreground Noise Processing.

Smearing Signal

Figure 27 presents a case of non-specific binding signal due to smearing. The contrast of this slide
image is increased for illustration, with the spot signal in red. The software detects and selects only
the signal due to local binding within each spot, highlighting the detected spots’ borders in blue to
show that the spot signal is unaffected by smearing from neighboring spots.

Figure 27: Smearing Processing.
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5.7 Background Correction

Starting with version 3.2, the software supports only the Local background correction method.

The software supports different levels of local background correction (see Figure 23, bottom-right).
The default for GAL files is the Block level.

e Block Level: All spots in a block have the same background value, computed from the mean
and median of the pixel intensity values of all background pixels in the block.

e Global Level: A global background value is calculated based on the background pixels of all
spots in the array.

e Spot Level: Each spot’s background value is based on its own background pixels, resulting in
potentially different background values between spots.
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6 Batch Processing

You can set up a batch to process multiple microarray images automatically. Suppose the experiment
involves screening a protein microarray with k samples. The microarray design is annotated by the
template array. From the screening results, you have k scanned images to quantify. For each scanned
image, the batch aligns the template array with the image, creates the GAL file with the aligned
layout, and generates the quantified data.

To create a batch, click the Batch button in the main toolbar (Figure 28). In the Batch control panel:

e C(Click the Add button and select the microarray images for processing. They will be added to
the scheduling table. Use the Add and Remove buttons to modify the table.

e Double-click on the Template array edit-box to browse to the template array file.

e Specify the folder to store generated files and the running mode.

e Save the batch to a file using the Batch > Save Batch menu. The batch log is created
automatically and named after the batch file.

We recommend using a separate folder for each batch to store the batch file and generated data.

“n

Since the software uses the dot character (“.”) for file extensions such as .gal or .csv, avoid naming
folders or files used in a batch with dot characters (except for the file extension) to prevent errors.

X Spotxel Microarray - o X

Project Images Arrays Analysis Batch Configurations View Help

Control Panel &| Carwas  Batch Processing
cee
see .
44 P — Scheduling Table
Images
Run Order  Image Status Aray GPRData  Quantified Data  Analysis Results Notes

1 image_001.4if Waiting

2 image_00Z.4f Waiting
Batch file “\tmp\batch2 1\demo.xml 3 image_003.4f | Waiting
Log file Datascansidemo_log.xml 4 image_004.tif Waiting
ey fcnmee 5 image_005.tif Waiting
[ image_006.tif Waiting
One template array for all images
Norm 7 image_007.tif Waiting
Template array ~ chData\templateArray.gal
8 image_008.tif Waiting
Store generated files in ] image_009.tif Waiting
HC
10 image_010.4if Waitin
© The image's folder 9 9
1 image_011.tif Waiting
PeA 12 image_012.4if Waiting
Tasks and Options
[ [ [ 13 image 013.tif Waiting
Batch 18 Array alignment 14 image_014.tif Waiting
8 Data quantification 15 image_015.1if Waiting

© Process all images continuously T image.016:5F Waiting

Stop and review after each image

Ready
Figure 28: Batch Setup.
After creating the batch, click the Run button to execute it (Figure 29). Note the running mode:

e Process all images continuously: The batch processes continuously without stopping.
e Stop and review after each image: You can view the batch results for one image before
proceeding to process the next one.
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X Spotxel Microarray
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Figure 29: Batch Execution.
Suppose that sample001.tif is an image in the batch. The software creates four data files for it:

e sample001.gal: The array file with the spot layout aligned to the image sample001.tif.
e sample001.csv: A CSV file containing only the quantified data.
e sample001.gpr: A file containing quantified data in the GenePix Result (GPR) format.

e sample001.spotxelproj: the Spotxel® Microarray project file containing the analysis data for
this image.
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7 Data Preprocessing and Normalization

The Data Preprocessing and Normalization tool (Figure 30) provides convenient ways to improve the
quality of microarray data. Replicate processing eliminates duplicates and stabilizes the features’
signal values by consolidating all replicates into a single value using their mean or median. Data
Filtering allows you to narrow the dataset and focus on features of interest. Data Normalization
reduces effects caused by technical variants, enabling data comparability to identify actual
relationships between samples and features.
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Figure 30: Replicate Processing, Data Filtering, and Data Normalization.

To launch the Data Preprocessing and Normalization tool, click the Norm button on the main toolbar.
The tool works on datasets containing the features’ signal values. Section 7.1 explains steps to
prepare a dataset from different sources. Replicate processing is explained in Section 7.2. Details on
data filtering and data normalization are provided in Sections 7.3 and 7.4, respectively.

7.1 Datasets

A dataset can be compiled from a list of Spotxel® Microarray project files. Consider the example in
Section 6 again, in which the protein microarray is screened with k samples. After running the batch,
we obtained k Spotxel® Microarray project files containing the quantified data. The dataset can be
represented as shown in Table 4, where V, is a screening value of Feature 1 when the microarray is
screened against Sample k and so on. The screening value can be chosen from the list of quantified

values, such as Red Foreground Mean.

The first five columns in Table 4 contain the spot’s properties specified in the GAL file (i.e., Block,
Row, Column, ID, and Name) of an individual feature (a protein in the batch example). For simplicity,

only the feature names are shown.
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Block | Row | Column | ID Name | Sample | Sample | .. Sample
1 2 k

Feature 1 V11 V12 Vlk

Feature n Vi1 V2 Vik

Table 4: A Sample Dataset.

You can also create a dataset from a list of GenePix Result (*.gpr) files by selecting the .gpr files and a
screening value such as F635Mean — B635. Alternatively, prepare a CSV file with the format shown in
Table 4, where the first five columns are Block, Row, Column, ID, and Name, and the subsequent
columns contain numeric values representing the signal values of the microarray features screened
against a sample.

To load a dataset from Spotxel Microarray project files or .gpr files, click the Load button in the
Dataset Files panel (Figure 30, top-left) and select the files. Specify the screening value in the Data
column list-box. If the dataset is already prepared as a CSV file, simply load that file. The dataset, with
both header and numeric columns, is shown in the table titled Original Dataset (Figure 30, top-
center).

Any dataset (original, filtered, or normalized) can be exported to a CSV file for further analysis. Select
the corresponding table (highlighted in green, such as the Normalized Dataset table in Figure 30,
bottom-center) and click the Export button in the Dataset Files panel. If there are more than two
tables of data, you can arrange them using the Window > Tile or Window > Cascade menu.

7.2 Replicate Processing

Suppose you print each feature (a protein or a gene) in duplicate, triplicates, or more on the
microarray for quality and error control. The signal value of a feature’s replicates is usually different.
In addition, you want only one an instance of the feature in the dataset. This can be done quickly
with the Replicate Processing tool.

In the Replicate Processing panel (Figure 30, bottom-left), select the header (such as Name or ID) in
the Unique header list-box. Then click the Process button. In each column of the dataset, features
having the same Name/ID will then be consolidated into one row. The new value will either be the
mean or the median of the feature’s replicates, as chosen at the Represent replicates’ value option. A
processed dataset is then stored in the Replicate Processing table (Figure 30, middle-center).

7.3 Data Filtering

You can narrow the currently selected dataset to certain rows containing features of interest using
header filters. These filters can contain or exclude specific keywords or match a regular expression®
search pattern. Additionally, you can select only features whose signal value is within a specified

® Regular expression - Wikipedia
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range using the lower and upper thresholds. These tools are provided in the Data Filtering panel
(Figure 30, top-right).

The header filter is set by first selecting the header column such as Name or ID. You then have the
following filtering options:

e (Contains: The dataset is narrowed to rows that contain one or more input keywords. A list of
keywords must be separate by AND/OR (in the exact uppercase form). For example “protein
OR positive” will select rows whose name contain “protein” or “positive”.

e FExclude: Rows whose header containing the keywords (separated by OR) are excluded from
the filtered dataset.

e Regular expression: This is the most powerful filter based on regular expression. Enter a
regular expression search pattern and press Enter to filter the dataset.

The minimum and maximum allowed values in the dataset can be set using the lower and upper
thresholds for the numeric columns. You can condition a row to satisfy all numeric columns or only a
number of them. Please note that a header filter has higher priority than the threshold setting. When
you apply a new header filter, the lower and upper threshold values will be reset to the minimum
and maximum values of the newly filtered dataset. Starting with these two thresholds, you can
narrow down the dataset based on the numeric values.

7.4 Data Normalization

Due to technical variations, the absolute signal values obtained directly after quantifying microarray
images may not comparably reflect the actual biological change. Data normalization is necessary to
make the data comparable again. The Data Normalization tool (Figure 30, bottom-right) provides
three methods to normalize the numeric values:

e Z-Score: Calculate the relative signal value of a feature as how far, in terms of standard
deviations, and in what direction a feature deviates from the center of all features.

e Z-Factor with negative controls: Check the screening quality using the standard deviation and
the mean value of screening features as well as those of negative controls (Zhang et al.,
2000)*.

e Ratio to mean value of controls: This is useful if the study employs some controls as
calibration probes. It calculates the normalized value as the ratio of the feature’s signal value
to the mean of selected controls’ signal value.

If you choose the latter two methods, click on the Select Controls button. This shows the Control
Selection dialog (Figure 31) with a list of all features in the currently selected dataset. There you can

choose one or more features as controls for the chosen normalization method.

4Zhang, J-H, Chung T.D.Y., and Oldenburg K.R. (2000) Confirmation of Primary Active Substances from High
Throughput Screening of Chemical and Biological Populations: A Statistical Approach and Practical
Considerations. J. Com. Chem. 2: 258-265
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After choosing a method, click on the Normalize button. The normalized dataset, titled Normalized
Dataset, is shown (Figure 30, bottom-center).

- ~
X Control Selection ﬁ
Header [Name A ]
contains | Selected controls
Name - Add > DunGS02_25_dT_dT
DunGS05_25_dT_dT
7 e
<< Remove
80 DphyexacutaFs01_25_dT ||
79 DunG502_25_dT_dT
64 DunGS505_25_dT_dT
3 Empty
34 EukS_1209 25 dT

[ OK ] [ Cancel

Figure 31: Control Selection for Data Normalization.
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8 Data Mining Tools

Data mining tools assist you in finding useful information from the microarray study. You can employ
Principal Component Analysis to discover features and samples that influence the study and then
Hierarchical Clustering Analysis to find their relationship. The batch processing results, i.e., generated
Spotxel® Microarray project files, can be used directly for data mining.

Please note that these tools work on datasets. The steps to prepare them from different sources are
described in Section 7.1.

8.1 Principal Component Analysis (PCA)

Principal Component Analysis (PCA) simplifies a complex microarray study to a more manageable one
with only a few samples or features, allowing you to observe the study’s data more easily. To begin,
click the PCA button in the main toolbar. In the PCA control panel (Figure 32):

o Click the Load Data button and select the dataset. Please refer to Section 7.1 for the
preparation of the dataset.

e Select a quantified value in the Data Column list-box.

e Choose to have the simplified dataset with either three Features or Samples.

e C(Click the Start Analysis button.

Control Panel Bl x
see
ces
see
Jmages Analysis X I
@ Load Data Start Analysis X Data projected on principal components 1 and 2 - o ®
Arays Data column
. Iris-versicolor
\ 1
- Analyze replicas fual (=]
Quantify
Simplify the dataset to three { ® °
® @
Norm Features © samples
58 [
o ¥y
Dataset in Table E., [
5 oy
HC g t..).
Eigenvalues © Original dataset S5 ° Q.’p.‘
Eigenvectors Simplified dataset E !‘?) . L]
) 3' L
PCA Export To CSV File ] °
6.16 LY
h) e e
Batch o L ®
695
17 1 9
" 1 Principal Component 1

Ready

Figure 32: Principal Component Analysis in 2D View.

Suppose you chose the Samples option. If the original dataset represents the features’ screening
value against multiple samples, PCA will simplify it to a dataset with only three key samples. Similarly,
you can discover such information about the samples by choosing the Features option before starting
the analysis.
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In the three charts (Figure 32), you can view the features according to their new values in the
simplified dataset. To zoom in on a region, use the mouse to select that region. Double-click on the
chart to return it to the original zoom.

In the Dataset in Table panel, you can choose to export the dataset, either original or simplified, to a
CSV file for further analysis.

In future releases, the PCA charts will be further improved for more intuitive and convenient use.

8.2 Hierarchical Clustering Analysis (HCA)

Hierarchical Clustering Analysis (HCA) allows you to group related features or samples. The
relationship can be, for example, having a similar effect in the study, represented by close screening
values. To set up the analysis, click the HC button in the main toolbar:

o Click the Load Data button and select the dataset. Please refer to Section 7.1 for the
preparation of the dataset.

e Select a quantified value in the Data Column list-box.

e Choose to construct the clustering tree for features, or samples, or both.

e Select the distance metric and the type of linkage. You can keep the default options.

e Click the Start Analysis button.

X Spotxel Microarray

Project Images Arrays Analysis Batch Configurations View Help

¥, Zoomin =) ZoomOut 100%

Control Panel 8 Canvas Hierarchical Clustering
eee
T Analysis
eee

Images
Load Data Start Analysis

Data column

Analyze replicas

Iris-versicolor
Iris-setosa
Iris-setosa
Iris-setosa

Create clustering trees for

@ Features B8 samples Iris-setosa
Norm Iris-setosa
Iris-setosa
HCA Options Iris-setosa
Iris-setosa
Iris-setosa
HC Distance metric Iris-setosa
Iris-setosa
Pearson Correlation
Block Column Row Name D sepal length sepal width petal length petal width
Linkage O Complete " 1 1 1 lris-setosa lris-setosa  -0.89767 1.02861 133679 -1.30859 1
PCA
Single 5 1 2 2 lrissetosa Iris-setosa 4113920 -0.12454 133679 -1.30859
[ » [ Weighted average
Vi 5 1 3 3 s-setosa  Iris-setosa 1.38073 033672 139347 130859
Unweighted average 3
Batch 1 4 4 rs-setosa  Iris-setosa -1.50149 0.10609 -128012  -1.30859
Dataset in table 4
5 1 5 5  lris-setosa lris-setosa 1.01844 1.25924 133679 130859
Export To CSV File 1 6 6 lrssetosa Iris-setosa  -0.53538 195113 116677 -1.04652

Ready

Figure 33: Hierarchical Clustering Analysis.

The clustering tree(s) are then constructed (Figure 33). Features that are considered related are
grouped into one cluster. Their relationship is represented by a line connecting them. A cluster might
be related to a feature or another cluster. The relationship between samples and clusters of samples

are represented similarly.
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The values in the dataset, each representing the screening value of a feature with a sample, are
graphically represented by means of a heat map. You can save the clustering trees with the heat map
to an image file using the Export to Image context menu.
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9 Product Activation
The product activation requires an internet connection. You need to have a serial number obtained
from the software provider or its distributors.

(1) Inthe Evaluation Time Has Expired dialog, click the Next button.

[ X Spotxel @1

Evaluation Time Has Expired!

The product needs to be activated with a valid Serial Number for further
use,

Click here to purchase a Serial Mumber.

Next | | End

Figure 34: Starting the Product Activation.

(2) Enter the serial number and the licensee information in the Product Activation dialog. Click Next.

X Spotxel @

Product Activation
Serial Number BPFPn-EXt4e-DE3cK-Ctg7Q-ROTE-3In4Y

First Mame Dale

Last Name Jones

Organization AZ Pharma Inc.

Email Address dale.jones@az-pharma.com

Click here to purchase a Serial Mumber.

Back | | mMext | | End

Figure 35: Entering the Licensee Information.

(3) If the internet connection is ready, click the Activate button and wait for the activation to finish.
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X Spotxel

Product Activation in Progress

The product will be activated online. Please prepare an internet connection
and dick Activate.

Proxy setting

Figure 36: Product Activation in Progress.

Please check the internet connection in the case the software could not reach the activation server. If
your system uses a proxy server to connect, specify it using the Proxy setting link. Otherwise, please

contact the software provider for support.

(4) A completion message is shown when the product is successfully activated. Click Next to use the

software immediately or End to use it later.

X Spotxel @

Product Activation is completed

Congratulation! You have successfully activated Spotwel.

Next | | End

Figure 37: Completion of the Product Activation.

Please note that the license can be reviewed, or renewed in the case of a time-limited license, by

clicking on the Help menu and choosing License Information.
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10 End-User License Agreement

SPOTXEL MICROARRAY IS THE PROPERTY OF SICASYS SOFTWARE GMBH ("SICASYS"). THE USE OF THIS
SOFTWARE IS GOVERNED BY THE TERMS AND CONDITIONS OF THE END-USER LICENSE AGREEMENT
("AGREEMENT") SET FORTH BELOW. THE TERM “SOFTWARE” ALSO INCLUDES RELATED
DOCUMENTATION (WHETHER IN PRINT OR ELECTRONIC FORM) AND ANY UPDATES OR UPGRADES
OF THE SOFTWARE PROVIDED BY SICASYS.

BY INSTALLING THE SOFTWARE, AND/OR BY USING THE SOFTWARE, YOU AGREE TO BE BOUND BY
THE TERMS AND CONDITIONS OF THIS END-USER LICENSE AGREEMENT.

License. SICASYS grants to you (“USER”) a non-exclusive, non-transferable license to use the
SOFTWARE on the number of computers stated in the license contract. A separate license is required
for use on any additional computer.

Copy Restriction. The SOFTWARE may not be copied either in full or part by USER, with the exception
of making copy for security or backup purpose. Copies must include all copyright and trademark
notices.

Use Restrictions. This SOFTWARE is licensed to USER for internal use only. USER shall not (and shall
not allow any third party to):

(i) decompile, disassemble, reverse engineer or attempt to reconstruct, identify or discover any
source code, underlying ideas, underlying user interface techniques or algorithms of the
SOFTWARE by any means whatever, or disclose any of the foregoing;

(ii) modify, incorporate into or with other software, or create a derivative work of any part of
the SOFTWARE;
(iii) attempt to circumvent any user limits, or other license, timing or use restrictions that are

built into the SOFTWARE.

Ownership of the SOFTWARE. SICASYS retains all titles of ownership, all ownership rights, and all
intellectual property rights of the SOFTWARE. SICASYS reserves all rights not expressly granted to
USER.

Termination. SICASYS may terminate this Agreement immediately if USER breaches any provision.
Upon notice of termination by SICASYS, all rights granted to USER under this Agreement will
immediately terminate, and USER shall cease using the SOFTWARE and return or destroy all copies of
the SOFTWARE.

Limited Warranty and Disclaimer. USER is aware of the fact that technical errors in the program in
accordance with the accompanying documentation cannot be excluded. If USER claims deviations in
the program from the specification/description, USER has the right to request a fix, patch, work-
around, or replacement of the SOFTWARE that does not meet such limited warranty. If a rectification
of the errors is not possible or if such rectification is not successful, USER has the right to request a
rescission of the contract, where USER must destroy all copies of the SOFTWARE.
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EXCEPT AS EXPRESSLY SET FORTH ABOVE, NO OTHER WARRANTIES OR CONDITIONS, EITHER
EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, ARE MADE BY SICASYS WITH RESPECT TO THE
SOFTWARE AND THE ACCOMPANYING DOCUMENTATION, AND SICASYS EXPRESSLY DISCLAIMS ALL
WARRANTIES AND CONDITIONS NOT EXPRESSLY STATED HEREIN, INCLUDING BUT NOT LIMITED TO
THE IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, NONINFRINGEMENT, AND
FITNESS FOR A PARTICULAR PURPOSE. SICASYS DO NOT WARRANT THAT THE FUNCTIONS
CONTAINED IN THE SOFTWARE WILL MEET USER’S REQUIREMENTS, BE UNINTERRUPTED OR ERROR
FREE, OR THAT ALL DEFECTS IN THE PROGRAM WILL BE CORRECTED. USER ASSUMES THE ENTIRE
RISK' AS TO THE RESULTS AND PERFORMANCE OF THE SOFTWARE.

Limitation of Liability. IN NO EVENT SHALL SICASYS BE LIABLE FOR ANY INDIRECT, SPECIAL,
CONSEQUENTIAL OR INCIDENTAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION,
DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTIONS, LOSS OF BUSINESS
INFORMATION, OR OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE
SOFTWARE, EVEN IF SICASYS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
FURTHER, IN NO EVENT SHALL SICASYS BE LIABLE FOR ANY DIRECT DAMAGES ARISING OUT OF
USER’S USE OF THE SOFTWARE. IN NO EVENT WILL SICASYS BE LIABLE TO USER FOR DAMAGES IN AN
AMOUNT GREATER THAN THE FEES PAID FOR THE USE OF THE SOFTWARE.

Intellectual Property Right Infringement. If a claim alleging infringement of an intellectual property
right arises concerning the SOFTWARE (including but not limited to patent, trade secret, copyright or
trademark rights), SICASYS in its sole discretion may elect to defend or settle such claim, and/or
terminate this Agreement and all rights to use the SOFTWARE, and require the return or destruction
of the SOFTWARE, with a refund of the fees paid for use of the SOFTWARE less a reasonable
allowance for use and shipping.

Miscellaneous. This Agreement is the entire agreement between USER and SICASYS with respect to
the SOFTWARE, and supersedes any previous oral or written communications or documents
(including, if USER is obtaining an update, any agreement that may have been included with the
initial version of the Software). This Agreement is governed by the laws of Germany. If any provision,
or portion thereof, of this Agreement is found to be invalid or unenforceable, it will be enforced to
the extent permissible and the remainder of this Agreement will remain in full force and effect.
Failure to prosecute a party’s rights with respect to a default hereunder will not constitute a waiver
of the right to enforce rights with respect to the same or any other breach.
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11 Third-Party Libraries

LibTIFF

This software uses the LibTIFF library. The LibTIFF library is provided under its own license. The full

text of the LibTIFF license is included below.

# LibTIFF license

Copyright © 1988-1997 Sam Leffler\
Copyright © 1991-1997 Silicon Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this software and

its documentation for any purpose is hereby granted without fee, provided
that (i) the above copyright notices and this permission notice appear in

all copies of the software and related documentation, and (ii) the names of
Sam Leffler and Silicon Graphics may not be used in any advertising or
publicity relating to the software without the specific, prior written
permission of Sam Leffler and Silicon Graphics.

THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,
EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR

ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND,

OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF
LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE

OF THIS SOFTWARE.

zlib

This software uses LibTIFF, which links to the zlib library. The zlib library is provided under the zlib

License. The full text of the zlib License is included below.

Copyright notice:

(C) 1995-2022 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or implied
warranty. In no event will the authors be held liable for any damages
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arising from the use of this software.

Permission is granted to anyone to use this software for any purpose,
including commercial applications, and to alter it and redistribute it
freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not
claim that you wrote the original software. If you use this software
in a product, an acknowledgment in the product documentation would be
appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be
misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.

Jean-loup Gailly Mark Adler
jloup@gzip.org madler@alumni.caltech.edu

libjpeg-turbo

This software uses LibTIFF, which links to the libjpeg-turbo library. The libjpeg-turbo library is
provided under the IJG License and the Modified BSD License. The full text of the Modified BSD
License is included below.

This software is based in part on the work of the Independent JPEG Group.

The Modified (3-clause) BSD License

Copyright (C)2009-2023 D. R. Commander. All Rights Reserved.<br>
Copyright (C)2015 Viktor Szathmary. All Rights Reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer.

- Redistributions in binary form must reproduce the above copyright notice,
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.

- Neither the name of the libjpeg-turbo Project nor the names of its
contributors may be used to endorse or promote products derived from this
software without specific prior written permission.
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THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS",
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

OpenCV

This software uses the OpenCV library version 4.9.0, which is licensed under the Apache 2 License.
The full text of the Apache 2 License is included below.
Apache License
Version 2.0, January 2004
http://www.apache.org/licenses/

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
1. Definitions.

"License" shall mean the terms and conditions for use, reproduction,
and distribution as defined by Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by
the copyright owner that is granting the License.

"Legal Entity" shall mean the union of the acting entity and all
other entities that control, are controlled by, or are under common
control with that entity. For the purposes of this definition,
"control" means (i) the power, direct or indirect, to cause the
direction or management of such entity, whether by contract or
otherwise, or (ii) ownership of fifty percent (50%) or more of the
outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity
exercising permissions granted by this License.

"Source" form shall mean the preferred form for making modifications,
including but not limited to software source code, documentation
source, and configuration files.

"Object" form shall mean any form resulting from mechanical
transformation or translation of a Source form, including but
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not limited to compiled object code, generated documentation,
and conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or
Object form, made available under the License, as indicated by a
copyright notice that is included in or attached to the work

(an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object
form, that is based on (or derived from) the Work and for which the
editorial revisions, annotations, elaborations, or other modifications
represent, as a whole, an original work of authorship. For the purposes
of this License, Derivative Works shall not include works that remain
separable from, or merely link (or bind by name) to the interfaces of,
the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including

the original version of the Work and any modifications or additions

to that Work or Derivative Works thereof, that is intentionally
submitted to Licensor for inclusion in the Work by the copyright owner
or by an individual or Legal Entity authorized to submit on behalf of
the copyright owner. For the purposes of this definition, "submitted"
means any form of electronic, verbal, or written communication sent
to the Licensor or its representatives, including but not limited to
communication on electronic mailing lists, source code control systems,
and issue tracking systems that are managed by, or on behalf of, the
Licensor for the purpose of discussing and improving the Work, but
excluding communication that is conspicuously marked or otherwise
designated in writing by the copyright owner as "Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity
on behalf of whom a Contribution has been received by Licensor and
subsequently incorporated within the Work.

2. Grant of Copyright License. Subject to the terms and conditions of
this License, each Contributor hereby grants to You a perpetual,
worldwide, non-exclusive, no-charge, royalty-free, irrevocable
copyright license to reproduce, prepare Derivative Works of,
publicly display, publicly perform, sublicense, and distribute the
Work and such Derivative Works in Source or Object form.

3. Grant of Patent License. Subject to the terms and conditions of
this License, each Contributor hereby grants to You a perpetual,
worldwide, non-exclusive, no-charge, royalty-free, irrevocable
(except as stated in this section) patent license to make, have made,
use, offer to sell, sell, import, and otherwise transfer the Work,
where such license applies only to those patent claims licensable
by such Contributor that are necessarily infringed by their
Contribution(s) alone or by combination of their Contribution(s)
with the Work to which such Contribution(s) was submitted. If You
institute patent litigation against any entity (including a
cross-claim or counterclaim in a lawsuit) alleging that the Work
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or a Contribution incorporated within the Work constitutes direct
or contributory patent infringement, then any patent licenses
granted to You under this License for that Work shall terminate
as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the
Work or Derivative Works thereof in any medium, with or without
modifications, and in Source or Object form, provided that You
meet the following conditions:

(a) You must give any other recipients of the Work or
Derivative Works a copy of this License; and

(b) You must cause any modified files to carry prominent notices
stating that You changed the files; and

(c) You must retain, in the Source form of any Derivative Works
that You distribute, all copyright, patent, trademark, and
attribution notices from the Source form of the Work,
excluding those notices that do not pertain to any part of
the Derivative Works; and

(d) If the Work includes a "NOTICE" text file as part of its
distribution, then any Derivative Works that You distribute must
include a readable copy of the attribution notices contained
within such NOTICE file, excluding those notices that do not
pertain to any part of the Derivative Works, in at least one
of the following places: within a NOTICE text file distributed
as part of the Derivative Works; within the Source form or
documentation, if provided along with the Derivative Works; or,
within a display generated by the Derivative Works, if and
wherever such third-party notices normally appear. The contents
of the NOTICE file are for informational purposes only and
do not modify the License. You may add Your own attribution
notices within Derivative Works that You distribute, alongside
or as an addendum to the NOTICE text from the Work, provided
that such additional attribution notices cannot be construed
as modifying the License.

You may add Your own copyright statement to Your modifications and
may provide additional or different license terms and conditions

for use, reproduction, or distribution of Your modifications, or

for any such Derivative Works as a whole, provided Your use,
reproduction, and distribution of the Work otherwise complies with
the conditions stated in this License.

5. Submission of Contributions. Unless You explicitly state otherwise,
any Contribution intentionally submitted for inclusion in the Work
by You to the Licensor shall be under the terms and conditions of
this License, without any additional terms or conditions.
Notwithstanding the above, nothing herein shall supersede or modify
the terms of any separate license agreement you may have executed
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with Licensor regarding such Contributions.

6. Trademarks. This License does not grant permission to use the trade
names, trademarks, service marks, or product names of the Licensor,
except as required for reasonable and customary use in describing the
origin of the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty. Unless required by applicable law or
agreed to in writing, Licensor provides the Work (and each
Contributor provides its Contributions) on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
implied, including, without limitation, any warranties or conditions
of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
PARTICULAR PURPOSE. You are solely responsible for determining the
appropriateness of using or redistributing the Work and assume any
risks associated with Your exercise of permissions under this License.

8. Limitation of Liability. In no event and under no legal theory,
whether in tort (including negligence), contract, or otherwise,
unless required by applicable law (such as deliberate and grossly
negligent acts) or agreed to in writing, shall any Contributor be
liable to You for damages, including any direct, indirect, special,
incidental, or consequential damages of any character arising as a
result of this License or out of the use or inability to use the
Work (including but not limited to damages for loss of goodwill,
work stoppage, computer failure or malfunction, or any and all
other commercial damages or losses), even if such Contributor
has been advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability. While redistributing
the Work or Derivative Works thereof, You may choose to offer,
and charge a fee for, acceptance of support, warranty, indemnity,
or other liability obligations and/or rights consistent with this
License. However, in accepting such obligations, You may act only
on Your own behalf and on Your sole responsibility, not on behalf
of any other Contributor, and only if You agree to indemnify,
defend, and hold each Contributor harmless for any liability
incurred by, or claims asserted against, such Contributor by reason
of your accepting any such warranty or additional liability.

END OF TERMS AND CONDITIONS
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12 Revision History

Revision | Date Changes
Rev 9 2025 New functions:

January - 3D Spot Viewer

03 Updated functions:

- Automatic array alignment

Rev 8 2024 New functions:

August - GAL file editor

14 - Feature-based spot finding

Removed functions:
- Background controls
- Scatter Plot & K-Means Clustering

- Image Intensity > Filter noise

- Quantification Options > “Include change of the images’ intensity value”

Spotxel® Microarray 3.5 User’s Guide
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13 Index

A

activate - 3, 37
array alignment - 9
automatically - 9
manually - 10
array editor
create - 10
edit- 12
extend - 12
shortcuts - 14
undo/redo - 14

H

hardware requirement - 3
HCA
clustering tree - 35
heat map - 36

B

background correction - 27
batch

execute - 28
block

properties - 9

image
resolution - 8
resolution options - 8
without resolution - 8
installation - 3
Mac OS X platforms - 3
Windows Platforms - 3
inversion - 16

C

canvas - 4,9
canvas toolbar - 4
cluster - 35
control panel - 4

license
End-User License Agreement - 39

D

data filtering
header filter - 32
data mining
dataset - 30, 34, 35
data normalization
ratio to mean value of controls - 32
Z-Factor - 32
Z-Score - 32

M

main toolbar - 4,5

menu - 4

N

noise

process noise at quantification - 26

F

file
Spotxel® project (*.spotxelproj) - 30
TIFF (*.tiff, *.tif) - 7

Spotxel® Microarray 3.5 User’s Guide

Q

quantification - 6
quantified data
export to CSV file - 22

R

replicate processing - 31
rotate
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array (blocks) - 16, 17 Feature-Based - 23
image - 16, 17 Fixed-Spot - 23
Flex-Spot - 23
Spot Viewer

S

two-dimensional - 21

serial number - 37

spot V4
properties - 9
smallest spot size - 24 zoom -9
spot detection method
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